« Previous - Version 15/20 (diff) - Next » - Current version
J. Simmons, 12/23/2016 01:58 pm


Software Set Up

Introduction

These instructions cover the software set up of a newly built Holoseat controller. There are three pieces of software required to configure and use the Holoseat: the Arduino IDE, the Holoseat controller firmware, and the desktop configuration app.

Note, these steps are for Windows (tested on Windows 7). The process is similar on other platforms, but the desktop configuration app only runs on Windows for v0.3. Future versions will support other platforms.

1. Download required Software

  1. Download the following files
    1. Arduino IDE (v1.6.4+)
    2. Adafruit Windows Drivers
    3. Firmware source code
    4. Desktop configuration app executable
  2. Unzip Holoseat files (see figure)
    1. Create a new folder under Documents\ named Holoseat
    2. Unzip the firmware source code to Documents\Holoseat
    3. Unzip the desktop configuration app to Documents\Holoseat

2. Install Arduino IDE

  1. Run the Arduino IDE installer
  2. Configure the Arduino IDE to work with the Feather board
    Complete details are available at learn.adafruit.com: General details | Feather specific details
    1. Launch the Arduino IDE
    2. Open the Arduino IDE Preferences by selecting File>Preferences from the menu
    3. Add https://adafruit.github.io/arduino-board-index/package_adafruit_index.json to the Additional Boards Manager URLs field
    4. Click the OK button to save the new preferences
    5. Launch the Boards Manager by selecting Tools>Board>Board Manager from the menu
    6. Select Contributed from the Type select box
    7. Select Adafruit AVR Boards by Adafruit in the list of contributed boards then click the Install button
    8. Click the Close button, then exit out of the Arduino IDE (you may optionally relaunch the Arduino IDE and verify the list of boards under Tools>Board includes the Adafruit Feather)
    9. ON WINDOWS ONLY Install the Windows Adafruit Drivers (optional: only select the Feather 32u4 to minimize the number of drivers installed)
  3. Copy the Arduino libraries to the Holoseat libs directory
    1. Launch the Arduino IDE
    2. Open the Arduino IDE Preferences by selecting File>Preferences from the menu
    3. Note the Sketchbook location (typically Documents\Arduino)
    4. Close the Arduino IDE Preferences and exit the Arduino IDE
    5. Copy Documents\Holoseat\Firmware\libs\Bounce2 to the libraries folder in the sketchbook folder (typically Documents\Arduino\libraries)

3. Install Firmware on Holoseat Controller

  1. Launch the Arduino IDE
  2. Plug the Holoseat controller into a USB port
  3. Set the board type to Adafruit Feather 32u4 by selecting Tools>Board>Adafruit Feather 32u4 in the menu
  4. Set the port the Feather is connected to by selecting Tools>Port>COM# (Adafruit Feather 32u4) in the menu where # is an integer (see figure)
  5. Open the Holoseat firmware in the Arduino by selecting File>Open and navigating to Documents\Holoseat\Firmware\holoseat_firmware\holoseat_firmware.ino
  6. Confirm the firmware compiles by clicking the Verify button (with the check mark icon)
  7. Flash the Holoseat controller with the firmware by clicking the Upload button (with the right facing arrow icon)

4. Install Desktop Configuration App

The desktop configuration app does not currently require any installation steps. You can run it directly from Documents\Holoseat\HoloseatConfigurationUtility

InstallFeatherDriver.png (42.5 kB) J. Simmons, 12/12/2016 06:56 pm

LibrariesFolder.png (78.8 kB) J. Simmons, 12/12/2016 07:05 pm

SelectComPort.png (48.8 kB) J. Simmons, 12/12/2016 08:16 pm

HoloseatDir.png (75.1 kB) J. Simmons, 12/22/2016 01:01 pm

Also available in: HTML TXT