Bug #66

Getting https error when embedding YouTube videos

Added by J. Simmons over 8 years ago. Updated about 8 years ago.

Status:Resolved Start date:06/14/2012
Priority:Normal Due date:
Assignee:J. Simmons % Done:

100%

Category:-
Target version:v0.2 - Public Beta

Description

Visit the Far Horizons Project Wiki Page to see the error. Error confirmed in Chrome and IE 9. Error message is "This page has insecure content".

It looks like there is a new option with embedding YouTube videos for HTTPS sites. See "Enabling HTTPS mode" on this page. We should update the Youtube/Vimeo plugin to work with this feature (and check Vimeo videos for similar problem).

History

Updated by J. Simmons over 8 years ago

Also need to check the Donation Drive Plugin for similar bugs.

Updated by J. Simmons over 8 years ago

  • Assignee changed from Matthew Sears to J. Simmons
  • % Done changed from 0 to 20

Confirmed the error is in the embed code being generated by the plugin. Currently fixed for youtube with a hack to the running source code. Need to go back in the svn repo and put an actual patch in place for youtube (note, would like to use Redmine protocol setting to determine whether we should use http or https). Still need to address the ChipIn Badge (other related wiki enhancements appear to be fine).

Updated by J. Simmons about 8 years ago

  • Status changed from New to Resolved
  • % Done changed from 20 to 100

Youtube and Chipin were the only widgets to have problems. Youtube is fixed, and Chipin does not work at all anymore. Filing new issue about Chipin, but we may just drop support for it since it looks like it is not longer being used.

Also available in: Atom PDF