Bug #43

Getting error when browsing repositories

Added by J. Simmons about 9 years ago. Updated almost 9 years ago.

Status:Closed Start date:11/03/2011
Priority:Urgent Due date:
Assignee:- % Done:

0%

Category:-
Target version:v0.2 - Public Beta

Description

If you browse to the Repository (such as in the repo in the sandbox project) tab in a project you get the following error:

An error occurred when trying to access the repository: Cannot allocate memory - 'svn' list --xml 'https://opendesignengine.net/svn/sandbox/'@HEAD --no-auth-cache - non-interactive

This appears to be related to issues in Redmine.

History

Updated by J. Simmons about 9 years ago

It looks like this is a pure use of memory issue. After further investigation I found the system was running at 99% memory usage. I tried to restart the ODE services using the bitnami control script, but the script did not kill the mongrel process. Did some more digging and I found the mongrel process and its startup commands in the Capistrano deployment script. Restarting mongrel using the commands from the deployment script restored repository access.

Next steps:

  1. Address process management processes in the wiki so it is more clear how to start/stop/restart the ODE services
  2. Find out how much memory we expect to be using and determine if this is a bug or a configuration issue
  3. Take appropriate corrective action based on research

Updated by J. Simmons almost 9 years ago

Not sure if this is related, but we just had what appears to be a mongrel crash. The work around was to remove the mongrel pid file under apps/ode/tmp/..... and then restart the ODE daemons using the bitnami control script.

Updated by J. Simmons almost 9 years ago

  • Status changed from New to In Progress

Updated by J. Simmons almost 9 years ago

  • Status changed from In Progress to Closed

We have not seen this issue in months. Closing until we can reproduce it.

Also available in: Atom PDF